How to convert V1 live reports to V2
Friday, December 2, 2016 4:42 AM

V2 live reports have an advantage over V1 in that they are easier to construct and the report data is embedded in the Excel file itself instead of retrieved from the FocalScope server. This article demonstrates the process of converting a V1 live report to the new V2 standard.

Prerequisites

Tutorial

Converting a V1 live report to V2 format

Use the source live report Excel file you created (or download the Excel template from FocalScope) for the live report that you want to convert to V2 and follow the rest of this procedure:


  1. After opening the source live report, click [Data tab > Connections] and remove the existing [RawData] connection
  2. Continued in next section...


Figure 1 - Deleting the existing 'RawData' connection

  1. Click [Formulas > Name Manager]
  2. Select and both the [DataURL] and [RawData] entries and click [Delete]
  3. Create a new entry by clicking [New]
  4. Continued in next section...


Figure 2 - Deleting unused names from the Name Manager


  1. Set the [Name] as RawData
  2. Set the [Scope] as [Workbook]
  3. Click the reference button (highlighted in red in Figure 3) to set the data range for the name
  4. Continued in next section...



Figure 3 - Adding a new 'RawData' name to the Name Manager



  1. Set the reference by selecting all the data fields and calculated fields horizontally (Ctrl+Shift+right arrow), and vertically select all rows to allow for any length of data entry (Ctrl+Shift+down arrow)
  2. Click [Ok] (as per Figure 3) to add the new RawData name to the Name Manager
  3. Continued in next section...



Figure 4 - Setting the data range for the RawData name

Please note: Save and reopen the report at this point before continuing. The final steps of the procedure involves updating the pivot tables/charts to use the new RawData name. Proceed as follows:



  1. For each pivot table / chart in the report, click [Options > Change Data Source] and set the data source as 'Raw Data'!RawData
  2. Continued in next section...



Figure 5 - Updating the data source for pivot tables / charts


  1. Finally, for each pivot table / chart in the report, right-click the pivot table and select [PivotTable Options]
  2. Select the [Data] tab in the [PivotTable Options] window
  3. Set the options as specified in Figure 6 and click [Ok]



Figure 6 - Setting the correct PivotTable options

Additional Information