Help center

View helpful articles, tutorials and FAQs on the set-up and configuration

of the FocalScope omnichannel suite, according to best practice.

Why are outgoing emails delayed or not sent at all?




Emails sent from within FocalScope can be delayed by various factors. FocalScope does not function as a mail server, so it depends on other systems to deliver email to the intended recipients.

Symptoms

  • People receive emails sent by you but only after a long delay (can be hours or even days)
  • People complain that they are not receiving emails you sent to them

Cause

  • Incorrect email account credentials have been used
  • The mail server offline or over-capacitated
  • The mail server has blacklisted the FocalScope server IP address
  • Incorrectly formatted email address in a mailing list


Troubleshooting

Testing the SMTP functionality for the associated email account

  1. In the [Main menu], select [Screen > Administration]
  2. Navigate to the corresponding email address of the affected folder(s)
  3. Pay attention especially to the [Check every: X min.] setting, server address, and account credentials
  4. Perform an SMTP test  to see if the email account is capable of sending emails



Figure 1 - SMTP test failure error message

Viewing errors related to outgoing emails that fail to send

  1. In the [Main menu], select [Screen > Administration]
  2. Click on the [Administration] tab
  3. Select the [Email status & error reporting > Outgoing traffic] folder
  4. Note the error message for the undelivered email



Figure 2 - Outgoing email error page


Solution

  • Ensure the correct email account details are entered in the [E-mail account Properties] window
  • White list the FocalScope server IP address in your mail server. See When testing an email account, the message ‘Connection refused’ is displayed for more information
  • Go through the list of email addresses in a mailing list and make sure all emails are correctly entered, properly formatted, and separated only by a semicolon ';'


Additional Information





Let us help

If you have any questions, or need further support, please don’t hesitate to reach out.