- Help center
- Email ticketing
- Troubleshooting
Error ‘Connection refused’ displayed in email test
You may get a Connection refused error while trying to connect to the email server where the emails are hosted. What follows is a list of symptoms, causes and possible resolutions for this specific error message.
Symptoms
- Errors that appear and disappear sporadically
- Authentication or login failed errors (despite the correct credentials being used, and having been successful in previous login attempts)
- No specific error messages except failed are given
- Connection refused error
- Delays in receiving emails caused by the sporadic connection drops
- Outgoing messages stuck in users [Outgoing] folders
- Red flashing ticketboxes
- Testing email accounts POP / SMTP / IMAP fails
Cause
The symptoms explained result from the email server reacting as if it were being attacked or abused. The email server may even suppress actual error messages or give error messages that are too ‘general’ to denote a specific problem. Sometimes, the email server may even blacklist the FocalScope hosting server IP address either permanently or for a certain duration, causing FocalScope to stop sending and receiving emails.
Unlike email clients such as Outlook, which run on individual computers with distinct IP addresses, collecting emails for their respective users, FocalScope collects emails for all the accounts which are configured from the IP address where the FocalScope instance is hosted. This may very often lead the email server misinterpreting this as an attack since a lot more traffic is generated from a single IP address.
The most likely reason for this is some restriction on the email server such as:
- Spam Control Mechanism
- Server is too busy to handle the request
- Some sort of server control mechanism has been triggered to restrict the FocalScope IP from connecting to the email server
- Firewalls restrictions
- The error will go away once the IP address where your FocalScope instance is hosted is white listed on the mail server and/or the firewalls
Please note, connection refused and Login failed error messages may be indicative of actual problems not related to the scenario detailed in this article. Please see the Additional Information section (below) for other potential causes of these errors.
Resolution
Whitelist the FocalScope application server IP address on the email server, and set any traffic limits to unlimited.
Additional Information
- How email loops occur between FocalScope and the email server
- Why is a personal or shared folder flashing red?
- Why are incoming emails delayed or not received at all?
- Why are outgoing emails delayed or not sent at all?