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How email loops occur between FocalScope and the email server
FocalScope can automatically send responses to incoming emails using its Autoresponder feature. However, if the incoming email has an erroneous [From] address, a loop may occur between FocalScope and the mail server. This loop causes a continuous flow of autoresponses to be sent between FocalScope and the mail server, which quickly appears as multiple threads in a ticketbox where the Autoresponder is enabled.
Symptoms
- New emails from a singe address keep appearing in a FocalScope folder and have the same message (usually a warning or a delivery failure notification)
- Multiple FocalScope autoresponses are sent to a single address and may get jammed in the outgoing folder (failing to be sent at all)
Cause
An incoming email may have a faulty [From] address, e.g., alice.smith@acme.con (as opposed to .com). When FocalScope's Autoresponder sends an autoresponse to the [From] address, the mail server responds later with an error message (because of the erroneous email address). The messages are usually along the lines of Transient Delivery Failure (or similar).
FocalScope then sends an autoresponse to the mail server's autoresponder (meaning the Mdaemon@mailserver email address - an invalid email address). The mail server then repeats the error message about not being able to deliver the message, and a loop is generated between FocalScope and the mail server as they continue sending autoresponses to each other.
Troubleshooting
If you see multiple, similar looking threads (usually from an email address, such as Mdaemon@mailserver) separated by short successions in time, you may have an email loop. Each thread will have an autoresponse from the FocalScope Autoresponder.
Solution
To resolve the problem, the email address(es) used by the email server for automated notifications should be put into the autoresponder exceptions list. This will stop FocalScope's Autoresponder from sending out an autoresponse to an error message received from the mail server; thus avoiding any potential automated email loops forming.
- Right click the affected folder and select [Properties]
- Click the [Auto Responder] tab
- Add the mail server email address to the [Exceptions list]